WordPress Automatic Updater: per il sysadmin che non deve chiedere mai!


Vi sarà capitato di sviluppare siti in wordpress per clienti, amici o chicchessia.

Vi sarà anche capitato di finire il sito e dire “ecco qua login e password per entrare, buon fortuna!” (si non tutti vogliono pagare per la maintenance del sito).

A questo punto avete due alternative:

1. Lasciare che il sito in questione non venga MAI aggiornato

2. Installare un plugin che in automatico provveda agli aggiornamenti, notificandovi (o notificando a qualcun altro), le sue attività.

Eccoci allora a parlare di Automatic Updater, un comodissimo plugin per WordPress che vi permetterà di tenere aggiornati i vostri siti senza fare niente, se non magari aprirli per veder se funzionano dopo un update.

Per installarlo fate così

– Dall’amministrazione del vosto sito wordpress andate su Plugin -> Aggiungi Nuovo

– Nel campo di ricerca inserite “Automatic Updater

– Il primo plugin è quello che fa per noi, cliccate “Installa Adesso

– Fatto!

Ora per configurarlo andate su Impostazioni -> Automatic Updater

Di seguito vi riporto uno screenshot con le impostazioni che utilizzo sul mio sito

Automatic Updater configuration section
Automatic Updater configuration section

 

Quel che vi cosiglio io è di spuntare assolutamente il core ed i plugin (se avete un sito che non vi permette di aggiornare il core di wordpress, non spuntatelo ovviamente, ma sappiate che non è buona prassi).

Per quanto riguarda i temi dipende se avete temi che supportano gli update o se avete fatto personalizzazioni (si qua ve lo concedo anche per i temi che potreste aggiornare automaticamente).

Per il resto, secondo me, vanno benissimo i valori di default.

Sino ad ora sono un 6 mesi che lo uso su un altro sito (da pochi giorni anche su questo), e non ho mai avuto problemi. Ogni 1-2 giorni mi arriva la notifica degli update e vivo felice 😉

Le email che arrivano sono tipo queste:

Salve!

Automatic Updater è stato appena eseguito sul tuo sito, http://www.lapueste.eu, con il seguente risultato:

È stato trovato un aggiornamento per un plugin!

Leaflet Maps Marker ®: Correttamente aggiornato dalla versione 3.5.4 alla versione 3.6!

Gli autori dei plugin si basano sui tuoi feedback per migliorare la qualità dei propri prodotti, e la comunità di WordPress fa riferimento ai voti dati ai plugins per valutarne l’utilizzo. Se hai un paio di minuti, clicca sul nome del plugin e lascia un voto o un commento!

Grazie di aver scelto il plugin Automatic Updater!

Fatemi sapere come vi trovate!!!

Un saluto a tutti

 


Lascia un commento

Il tuo indirizzo email non sarà pubblicato.

Per postare il commento, risolvi il quesito sottostante * Time limit is exhausted. Please reload CAPTCHA.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.