Skype: dal 1° agosto problemi di autenticazione su Ubuntu

Dal 1° agosto 2014 ho iniziato a riscontrare problemi con il login su Skype 4.2 sul mio desktop con Ubuntu 14.04 (mi dicono che il problema sussista anche con Ubuntu 12.04, questa guida vale anche per questa versione).

Grazie alla segnalazione dell’amico Matteo Moro vi riporto una breve guida, su come rimuovere la vecchia versione di Skype 4.2 ed installare la 4.3 che risolve il problema.

Come avrete visto la versione 4.3 di skype non è ancora disponibile per Ubuntu 14.04, ciò non toglie che si possa comunque installare, vediamo come:

Rimuoviamo le versioni precedenti

sudo apt-get remove skype skype-bin:i386 skype:i386
sudo apt-get install sni-qt:i386

Installiamo Skype.

Per sistemi a 32-bit:

sudo apt-get install gdebi
wget download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
sudo gdebi skype-ubuntu-precise_4.3.0.37-1_i386.deb

Per sistemi a 64-bit:

sudo dpkg --add-architecture i386
sudo apt-get update
sudo apt-get install gdebi
wget download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
sudo gdebi skype-ubuntu-precise_4.3.0.37-1_i386.deb

 

Facciamo pulizia della vecchia installazione di Skype

Può tornarci utile fare pulizia delle vecchie impostazioni di skype, possiamo procedere così

cd ~ && rm -r .Skype

 

Author: Matteo Temporini

Nato nel 1979 a Udine (Italia), ho conseguito il diploma di scuola superiore come Programmatore. Ho proseguito gli studi ottenendo nel 2006 la Laurea in Informatica, presso l'università degli studi di Udine. Da sempre appassionato al mondo del Web, ho maturato un esperienza decennale come sistemista Linux e Windows presso varie aziende. Quello che state leggendo su questo sito è frutto della mia esperienza diretta, che continua a crescere grazie ad amici e colleghi.

Share This Post On

18 Comments

  1. Prova

  2. Non ho la più pallida idea di cosa tu mi abbia fatto fare, ma …. Funziona!!! Quindi posso solo dire grazie infiniteeeee!! ;-D

  3. Salve. Ho provato a seguire queste operazioni, ma alla fine mi esce ” … Continuare? [S/n] S
    Interrotto.” …
    come posso procedere?
    Grazie.

  4. Rilancia il comando, e attenzione quando fai copia/incolla

  5. purtroppo mi dà sempre lo stesso messaggio.

  6. Mi pare molto strano, riportami il log della console.

  7. [email protected]:~$ sudo dpkg –add-architecture i386
    [sudo] password for ubuntu:
    Riprovare.
    [sudo] password for ubuntu:
    [email protected]:~$ ubuntu
    ubuntu: comando non trovato
    [email protected]:~$ sudo dpkg –add-architecture i386
    [email protected]:~$ sudo apt-get update
    Ign http://it.archive.ubuntu.com trusty InRelease
    Ign http://extras.ubuntu.com trusty InRelease
    Ign http://archive.canonical.com quantal InRelease
    Ign http://it.archive.ubuntu.com trusty-updates InRelease
    Trovato http://extras.ubuntu.com trusty Release.gpg
    Trovato http://archive.canonical.com quantal Release.gpg
    Ign http://it.archive.ubuntu.com trusty-backports InRelease
    Trovato http://extras.ubuntu.com trusty Release
    Ign http://it.archive.ubuntu.com trusty-security InRelease
    Trovato http://archive.canonical.com quantal Release
    Trovato http://it.archive.ubuntu.com trusty Release.gpg
    Trovato http://extras.ubuntu.com trusty/main Sources
    Trovato http://archive.canonical.com quantal/partner amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates Release.gpg
    Trovato http://extras.ubuntu.com trusty/main amd64 Packages
    Trovato http://archive.canonical.com quantal/partner i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports Release.gpg
    Trovato http://it.archive.ubuntu.com trusty-security Release.gpg
    Trovato http://extras.ubuntu.com trusty/main i386 Packages
    Trovato http://it.archive.ubuntu.com trusty Release
    Trovato http://it.archive.ubuntu.com trusty-updates Release
    Trovato http://it.archive.ubuntu.com trusty-backports Release
    Trovato http://it.archive.ubuntu.com trusty-security Release
    Trovato http://it.archive.ubuntu.com trusty/main amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty/restricted amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty/universe amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty/multiverse amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty/main i386 Packages
    Trovato http://it.archive.ubuntu.com trusty/restricted i386 Packages
    Trovato http://it.archive.ubuntu.com trusty/universe i386 Packages
    Trovato http://it.archive.ubuntu.com trusty/multiverse i386 Packages
    Ign http://archive.canonical.com quantal/partner Translation-it_IT
    Trovato http://it.archive.ubuntu.com trusty/main Translation-it
    Ign http://extras.ubuntu.com trusty/main Translation-it_IT
    Ign http://archive.canonical.com quantal/partner Translation-it
    Trovato http://it.archive.ubuntu.com trusty/main Translation-en
    Ign http://extras.ubuntu.com trusty/main Translation-it
    Ign http://archive.canonical.com quantal/partner Translation-en
    Ign http://extras.ubuntu.com trusty/main Translation-en
    Trovato http://it.archive.ubuntu.com trusty/multiverse Translation-it
    Trovato http://it.archive.ubuntu.com trusty/multiverse Translation-en
    Trovato http://it.archive.ubuntu.com trusty/restricted Translation-it
    Trovato http://it.archive.ubuntu.com trusty/restricted Translation-en
    Trovato http://it.archive.ubuntu.com trusty/universe Translation-it
    Trovato http://it.archive.ubuntu.com trusty/universe Translation-en
    Trovato http://it.archive.ubuntu.com trusty-updates/main amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates/restricted amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates/universe amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates/multiverse amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates/main i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates/restricted i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates/universe i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates/multiverse i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-updates/main Translation-en
    Trovato http://it.archive.ubuntu.com trusty-updates/multiverse Translation-en
    Trovato http://it.archive.ubuntu.com trusty-updates/restricted Translation-en
    Trovato http://it.archive.ubuntu.com trusty-updates/universe Translation-en
    Trovato http://it.archive.ubuntu.com trusty-backports/main amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports/restricted amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports/universe amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports/multiverse amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports/main i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports/restricted i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports/universe i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports/multiverse i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-backports/main Translation-en
    Trovato http://it.archive.ubuntu.com trusty-backports/multiverse Translation-en
    Trovato http://it.archive.ubuntu.com trusty-backports/restricted Translation-en
    Trovato http://it.archive.ubuntu.com trusty-backports/universe Translation-en
    Trovato http://it.archive.ubuntu.com trusty-security/main amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-security/restricted amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-security/universe amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-security/multiverse amd64 Packages
    Trovato http://it.archive.ubuntu.com trusty-security/main i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-security/restricted i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-security/universe i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-security/multiverse i386 Packages
    Trovato http://it.archive.ubuntu.com trusty-security/main Translation-en
    Trovato http://it.archive.ubuntu.com trusty-security/multiverse Translation-en
    Trovato http://it.archive.ubuntu.com trusty-security/restricted Translation-en
    Trovato http://it.archive.ubuntu.com trusty-security/universe Translation-en
    Ign http://it.archive.ubuntu.com trusty/main Translation-it_IT
    Ign http://it.archive.ubuntu.com trusty/multiverse Translation-it_IT
    Ign http://it.archive.ubuntu.com trusty/restricted Translation-it_IT
    Ign http://it.archive.ubuntu.com trusty/universe Translation-it_IT
    Lettura elenco dei pacchetti… Fatto
    W: Duplicate sources.list entry http://archive.canonical.com/ quantal/partner amd64 Packages (/var/lib/apt/lists/archive.canonical.com_dists_quantal_partner_binary-amd64_Packages)
    W: Duplicate sources.list entry http://archive.canonical.com/ quantal/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_dists_quantal_partner_binary-i386_Packages)
    W: È consigliato eseguire “apt-get update” per correggere questi problemi
    [email protected]:~$ sudo apt-get install gdebi
    Lettura elenco dei pacchetti… Fatto
    Generazione albero delle dipendenze
    Lettura informazioni sullo stato… Fatto
    I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
    libasound2:i386 libasound2-plugins:i386 libasyncns0:i386 libdrm-intel1:i386
    libdrm-nouveau2:i386 libdrm-radeon1:i386 libelf1:i386 libflac8:i386
    libgl1-mesa-dri:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386
    libgstreamer-plugins-base1.0-0:i386 libgstreamer1.0-0:i386
    libjack-jackd2-0:i386 libllvm3.4:i386 libogg0:i386 liborc-0.4-0:i386
    libpciaccess0:i386 libpulse0:i386 libqt4-opengl:i386 libqtwebkit4:i386
    libsamplerate0:i386 libsndfile1:i386 libspeexdsp1:i386 libsqlite3-0:i386
    libssl1.0.0:i386 libtxc-dxtn-s2tc0:i386 libvorbis0a:i386 libvorbisenc2:i386
    libwrap0:i386 libx11-xcb1:i386 libxcb-dri2-0:i386 libxcb-dri3-0:i386
    libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386 libxdamage1:i386
    libxfixes3:i386 libxml2:i386 libxshmfence1:i386 libxslt1.1:i386 libxss1:i386
    libxv1:i386 libxxf86vm1:i386
    Usare “apt-get autoremove” per rimuoverli.
    I seguenti pacchetti saranno inoltre installati:
    gdebi-core gksu libcairo-perl libgksu2-0 libglib-perl libgtk2-perl
    libpango-perl
    Pacchetti suggeriti:
    libfont-freetype-perl libgtk2-perl-doc
    I seguenti pacchetti NUOVI saranno installati:
    gdebi gdebi-core gksu libcairo-perl libgksu2-0 libglib-perl libgtk2-perl
    libpango-perl
    0 aggiornati, 8 installati, 0 da rimuovere e 10 non aggiornati.
    È necessario scaricare 1.352 kB di archivi.
    Dopo quest’operazione, verranno occupati 6.030 kB di spazio su disco.
    Continuare? [S/n] S
    Interrotto.
    [email protected]:~$

  8. Mmm… prova a lanciare questi comandi

    sudo apt-get update
    sudo apt-get upgrade
    sudo apt-get autoremove
    sudo apt-get install gdebi

  9. alla fine mi dà questo:

    ……..
    Lettura elenco dei pacchetti… Fatto
    W: Duplicate sources.list entry http://archive.canonical.com/ quantal/partner amd64 Packages (/var/lib/apt/lists/archive.canonical.com_dists_quantal_partner_binary-amd64_Packages)
    W: Duplicate sources.list entry http://archive.canonical.com/ quantal/partner i386 Packages (/var/lib/apt/lists/archive.canonical.com_dists_quantal_partner_binary-i386_Packages)
    W: È consigliato eseguire “apt-get update” per correggere questi problemi
    [email protected]:~$

  10. Si non è un problema, dai anche gli altri comandi.

  11. scusami, quali altri comandi? grazie e scusami, ma ho poca dimestichezza. Sto imparando ora.

  12. Da quello che mi hai incollato, mi pare tu abbia dato solo il comando sudo apt-get update, dovresti darmi l’output anche dei comandi

    sudo apt-get upgrade
    sudo apt-get autoremove
    sudo apt-get install gdebi

  13. Grazie mille ho risolto! E magicamente ho ridato i comandi e funziona 🙂

  14. Ho seguito tutti i passaggi ma alla fine Skype non funziona nè si avvia. Soltanto scrivendo il comando LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype
    Skype riesce a partire e funzionare, ma non si crea il collegamento sul launcher e una volta chiuso il terminale si chiude anche il programma, costringendomi a riscrivere il programma ogni volta nella console per riavviare skype.
    Cosa posso fare?
    Grazie

  15. Ho seguito tutti i passaggi ma alla fine Skype non funziona nè si avvia. Soltanto scrivendo il comando LD_PRELOAD=/usr/lib/i386-linux-gnu/mesa/libGL.so.1 skype
    Skype riesce a partire e funzionare, ma non si crea il collegamento sul launcher e una volta chiuso il terminale si chiude anche il programma, costringendomi a riscrivere il programma ogni volta nella console per riavviare skype.
    Cosa posso fare?
    Grazie

  16. Finalmente …
    Grazie mille, funziona anche a me!

Submit a Comment

Il tuo indirizzo email non sarà pubblicato. I campi obbligatori sono contrassegnati *

Per postare il commento, risolvi il quesito sottostante * Time limit is exhausted. Please reload CAPTCHA.

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.